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[障害/復旧済み] ecforce ma ビジュアルエディタにて作成したメールテンプレートにて画像が表示されない件につきまして(11/12火 20:40更新)

平素は格別のご高配を賜り厚く御礼申し上げます。

ecforce maのメールテンプレートをビジュアルエディタを利用して作成した場合に、挿入した画像が正しく表示されない事象が発生しておりました。

事象

  • ecforce ma管理画面内、[配信テンプレート > メッセージ]にて「ビジュアルエディタ」を利用してアップロードした画像をメール内に挿入している場合、メッセージプレビュー及び実際に配信されたメール内にて画像の表示が行われない
  • 画像リンクをクリックすると、以下のようなエラーが表示される
This XML file does not appear to have any style information associated with it. The document tree is shown below.
<Error>
<Code/>
<Message/>
<RequestId> xxxxxx
<HostId>{host-id}</HostId>
<LambdaGeneratedError>true</LambdaGeneratedError>
</Error>

影響時間

11/1(金)頃 ~ 11/9(土) 1:54 AM

原因

前提として、ecforce maのビジュアルエディタにつきましては外部ツールを使用して構築しております。
この度使用している外部ツール側にて仕様変更があり、外部ツールのアップロード機能を活用しアップロードした画像の一部がリンク切れになってしまう事象が発生しておりました。
本事象の原因としては以下2つの仕様変更がございました。

①外部ツールサーバーにアップロードされている一部ファイルにアクセスできなくなった
- もともとビジュアルエディタを使用してアップロードされた画像は外部ツールサーバーに保管されておりましたが、外部ツールの仕様変更により、一部の画像URLへのアクセスができなくなってしまっておりました。


②1つの画像ファイルにつき24時間以内のアクセス数が1万件を超える、またはデータ転送量が1GBを超えると、当該画像がアクセス不可になってしまう
- メールに画像が挿入されている場合、開封の都度画像が読み込まれることになるため、メールの開封回数分がアクセス回数とみなされます。そのため、24時間以内に大量のメール開封が行われた場合、外部ツール側のサーバーに負荷がかかり、一部の画像のリンク切れが発生してしまっておりました。

▼アップロード箇所

スクリーンショット 2024-11-08 12.32.25.png

それぞれの対処につきましては以下に記載いたします。

暫定対処

2つの原因に対する暫定対処を記載いたします。

①外部ツールサーバーにアップロードされている一部ファイルにアクセスできなくなった

外部ツール側より復旧連絡があり、本事象は11/9(土) 1:54 AMに解消されたことを確認済みです。

②1つの画像ファイルにつき24時間以内のアクセス数が1万件を超える、またはデータ転送量が1GBを超えると、当該画像がアクセス不可になってしまう

②の影響によりアクセス不可になっている画像を含むテンプレートを保存・再保存する際には、管理画面上でエラーを表示するようにいたしました。
また、本制約を受けている画像ファイルの復旧につきましては、弊社サポート担当より個別にご連絡差し上げておりますため、恐れ入りますがご連絡があり次第ご対応をお願いいたします。

恒久対処

2つの原因に対する恒久対処を記載いたします。

①外部ツールサーバーにアップロードされている一部ファイルにアクセスできなくなった

ビジュアルエディタにてアップロードされた画像につきましては、外部ツールサーバーにアップロードされる仕様となっておりましたが、弊社にて管理しているサーバー配下にアップロードされるように仕様変更いたしました。(11/11(月) 13:30 対応完了)
これにより、画像URLは弊社管理のものに変更されますので、アクセス不可となる事象は再発いたしません。
なお、現在ビジュアルエディタを利用してアップロードされている画像につきましては、弊社側で全てバックアップを作成のうえ、今後の参照先を弊社サーバーに変更いたしましたのでショップ様にて作業を行っていただく必要はございません。

②1つの画像ファイルにつき24時間以内のアクセス数が1万件を超える、またはデータ転送量が1GBを超えると、当該画像がアクセス不可になってしまう

弊社管理のサーバーにはアクセス制限及びデータ転送量の制限はございませんので、①の恒久対処をもって②の事象も今後は発生いたしません。

このたびはご迷惑をおかけいたしまして誠に申し訳ございません。
本件についてお問い合わせがございます場合には、ecforceカスタマーサポートまでご連絡をお願いいたします。

今後とも、変わらぬご愛顧を賜りますよう、何卒よろしくお願いいたします。

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